Projeto: Vermelho

logs of development
スポンサーサイト

一定期間更新がないため広告を表示しています

| - | | - | -
AptanaにRadRails Development Environmentを組み込むときにエラー
aptanaのSoftwareUpdateからRadrailsプラグインをアップデートしようとすると,エラーになる.
Aptana Radrails integrationがひっかかっている.エラーメッセージは以下の通り.

Ruby Mylyn Connector feature (Optional)(0.9.1.XXXXXX) requires features "org.eclipse.mylyn.context_feature(2.0.0.vXXXXXXX)", or later


Mylynに関するなにかが必要なようだ.Mylynは,Eclipse3.3から組み込まれた新しい機能らしい.しかし,結果として必要なさそうなのだが,でも気になる.

そこで,MylynをインストールできるようにSoftwareUpdateにダウンロードのURIを設定する.

Name:Mylyn
URL: http://download.eclipse.org/tools/mylyn/update/e3.3

しかしこれでもエラーが出る.
とりあえず,Aptana radrails Integrationのインストールを諦めた.
| IDE_aptana | 15:11 | comments(0) | trackbacks(0)
aptanaをインストールし,実行する.
http://aptana.com/からダウンロード

LinuxにAptanaをインストール
aptanaディレクトリをどこかにおく(/usr/local/src以下がいいらしい)

/usr/local/binに実行ファイルAptanaとstartup.jarのシンボリックリンクをおく
$ln -s /usr/local/src/aptana/Aptana /usr/local/bin/
$ln -s /usr/local/src/aptana/startup.jar /usr/local/bin/

インストールが終わったら,Help>Software Updateからpluginをインストールする.
| IDE_aptana | 14:07 | comments(0) | trackbacks(0)
[Rails]aptanaに既存プロジェクトを読み込む
Eclipseを起動し、aptana(RadRails)を選択する。

ファイル→新規プロジェクト→RailsProjectを選択

Optionsから、以下のチェックをはずす。
  • Generate Rails application skeleton

  • Create a WEBric server


    • このとき、プロジェクトの取り込みが空振りする場合には、プロジェクトディレクトリの書き込み権限を調べてみる。aptanaは、ログインしているユーザで実行される。ディレクトリの所有者がログインユーザではない場合、もしくはグループに書き込みできる権限がない場合には、ディレクトリのユーザをログインユーザにマッチさせるか、グループに書き込み権限を付与する必要がある。
| IDE_aptana | 23:15 | comments(0) | trackbacks(0)